Replies: 1 (Who?), Viewed: 87 times.
Virtual gardener
staff: administrator
Original Poster
#1 Old 30th Jul 2022 at 1:06 PM
Default Editing Bin Sims (and putting them in the world) causes all sorts of weirdness
Heya!

Yep, yet another thread I figured I'd make a new one, but it's indeed still about the bin sims.

I've currently been successfully editing Bin sims/households. More specifically the information of said bin household (Such as their starting money and any sims that should be pregnant).

Problem however is... after I place them on a lot, nraas and the game throw a bunch of null references that are very initializing-related errors. (Such as HUD population of skills, etc).

This is basically what I see, mind you, there are supposed to be 2 sims in this household, it only shows one:



Not exactly playable :p


Here's the function where things go wrong:



Regarding what GoThroughQuestionare() does, currently, it's a relatively small snippet that changes the family funds money:



However, it seems that even *touching* Household or any sims in them, and changing any data, does some serious damage to a point that the game won't let me actually play with those sims... And I can't quite figure out why. Any ideas?
Screenshots
Advertisement
Virtual gardener
staff: administrator
Original Poster
#2 Old 30th Jul 2022 at 3:25 PM
Hrm upon doing a lot of testing around, I've come to the conclusion that on Edit Town > Bin editing is all fine and works, but in Playflow this isn't the case.

Probably because on the PlayFlowState not everything has been properly set? And that therefore a lot of null references appear... I'll leave the bin editing option in edit town then, though if anyone has any suggestions to get this to work on the PLayFlow state, that would be great!
Back to top