Replies: 2 (Who?), Viewed: 147 times.
Lab Assistant
Original Poster
#1 Old 29th Aug 2022 at 7:50 PM
Default Help with custom trait
I'm making a custom reward trait that makes sims paint faster. But ran into a problem where the game crashes when I load up my save. I have Scumbumbo's XML Injector installed and I exported the trait from Mod Constructor V5. Are there perhaps any code changes that I need to make to the tuning data prevent the crash? I have been following Scarlet's tutorials on SimsVIP, although I'm not sure if the tuning files in the package still need to be changed for it to work with the Cats & Dogs patch, or if Mod Constructor V5 accounts for this and later updates.

Link to the mod
Last Exception
Screenshots
Advertisement
Field Researcher
#2 Old 31st Aug 2022 at 6:41 PM
Why the <GroupKey> on the trait and buff tuning? That's the only part that catches my eye at first glance.
Lab Assistant
Original Poster
#3 Old 1st Sep 2022 at 3:35 PM
Quote:
Originally Posted by baniduhaine
Why the <GroupKey> on the trait and buff tuning? That's the only part that catches my eye at first glance.

I think Mod Constructor (V5) automatically generated the <GroupKey> tags. I'm not sure what they're meant to do. I tried running the game with the <GroupKey> tags removed, and at first I thought they were the cause of the crash. But when I put them back in, the game didn't crash this time. I suppose the crash wasn't related to the trait.

But, I'm having trouble making the trait appear in the rewards menu. I've added the reward trait snippet into the package while following the XML Injector documentation, but the trait still won't show up in game. No clue what I borked up.
Here's the link to the trait with the snippet added to it.
Back to top