Locked thread | Replies: 1478 (Who?), Viewed: 287180 times.
Page 2 of 60
Field Researcher
#26 Old 6th Jan 2006 at 7:21 PM
Quote:
Originally Posted by Lethe_s
Pistachio,
the file you uploaded is only the recolour,
most of the time, when recolours don't work, it's a faulty line in the gmnd of the mesh (you might want to check the 'designmodeEnabled' line specifically)
could you upload the mesh as well?


the rar attached to my post definitly has both packages in it, k8-oxygenisland-050106 is the original and k8-oxygenisland-recol-050106 is the recolour. It sounds likely there's a problem with the GMND but I'm well past the looking but not seeing stage!

www.parsimonious.org
Artists - Get your own Studio! Always be featured!
Field Researcher
#27 Old 6th Jan 2006 at 7:23 PM
Quote:
Originally Posted by IgnorantBliss
Do you mean you can't see your painting at all, or you just can't see the recolor you made? Do you mean you can't see any custom painting created by other people, either? Do you have custom content enabled in your game?


Or maybe you mean that when you go to load the painting in Object Workshop to start making your recolor you can't find it. When you recolor a custom object you have to hit "open" instead of "start" and then browse for the object you want to recolor.
Part-time Hermit
#28 Old 6th Jan 2006 at 7:24 PM
Quote:
Originally Posted by Mage
Or maybe you mean that when you go to load the painting in Object Workshop to start making your recolor you can't find it. When you recolor a custom object you have to hit "open" instead of "start" and then browse for the object you want to recolor.


Yes, that's what he meant, I'm sure! I kept thinking about the in-game catalog.
Lab Assistant
#29 Old 6th Jan 2006 at 7:32 PM Last edited by Ben♣ : 6th Jan 2006 at 7:38 PM.
Quote:
Originally Posted by IgnorantBliss
Do you mean you can't see your painting at all, or you just can't see the recolor you made? Do you mean you can't see any custom painting created by other people, either? Do you have custom content enabled in your game?

I'm sorry, I didn't explain the problem clearly :sorry:

I just mean I can't find my object and objects I download in "decorative > wall" in SimPe's Object Workshop ! I have no problem in the game .

I don't understand why an object doesn't appear in the object workshop's list whereas the creator did recolor it !

Example : I downloaded the boombox at Lyran. As you can see, the object has been recolored by the creator whereas I can't find it in the object workshop.

I want :
- to be able to recolor my object.
- people to be able to recolor my object.

EDIT : I was writing this post when you posted.

Thank you IB and Mage

- Speech is silver but silence is gold -
Field Researcher
#30 Old 6th Jan 2006 at 8:29 PM
Lol asking and answering is quite an exercise in using English.
Fluffy
retired moderator
#31 Old 6th Jan 2006 at 8:34 PM
[QUOTE=IgnorantBliss]Lethe, the mesh was included in the package that I downloaded.
[\QUOTE]

odd, I just tried again and I only get the recolor
computer must be tired or something :disagree:
Part-time Hermit
#32 Old 6th Jan 2006 at 8:42 PM Last edited by IgnorantBliss : 17th Feb 2006 at 7:45 PM. Reason: Removed old attachment
Quote:
Originally Posted by Lethe_s
[QUOTE=IgnorantBliss]Lethe, the mesh was included in the package that I downloaded.
[\QUOTE]

odd, I just tried again and I only get the recolor
computer must be tired or something :disagree:


That's very strange. Let me try uploading the file in this post, if it works for you. I'm going to need help from someone else with Kate's counter because I still haven't gotten anywhere after spending about an hour working on it. This is a tough one
Field Researcher
#33 Old 7th Jan 2006 at 3:46 AM
Quote:
Originally Posted by IgnorantBliss

I'm going to need help from someone else with Kate's counter because I still haven't gotten anywhere after spending about an hour working on it. This is a tough one


Thats oddly comforting on the level that at least it isn't just me haha! The awful thing is this was the last item I did in the set and everything else works perfectly :mad: usually I've done something so incredibly dumb and obvious that even I spot my mistake but I just can't fathom it.

www.parsimonious.org
Artists - Get your own Studio! Always be featured!
Part-time Hermit
#34 Old 7th Jan 2006 at 5:02 AM
Quote:
Originally Posted by Pistachio
Thats oddly comforting on the level that at least it isn't just me haha! The awful thing is this was the last item I did in the set and everything else works perfectly :mad: usually I've done something so incredibly dumb and obvious that even I spot my mistake but I just can't fathom it.


Maybe, if nothing else works, try cloning another island and see if there was just something wrong with this one? And, like I said, if you have a matching normal counter, try linking them together. The problem with kitchen counters at the moment is that you need a stand-alone clone to get all the necessary textures, but then you lose all the links to other objects. Quaxi has been informed about this, it's a problem with SimPE not pulling all the needed files.
Fluffy
retired moderator
#35 Old 7th Jan 2006 at 8:47 AM
ok, sorry folks, WinRAR was acting up, thank the gods or Delphy for Q-Xpress
now, kate,
I haven't been able to fix your package, but I have a theory
and Ignorant Bliss is, as always, right
your kitchen island contains tsMaterialsMeshName files, which are usually only found in slave objects
the original object was never meant to have its own recolours, I think, and it may not have 'internal' links that allow recoloring SimPE pulls all the necessary files, but I'm not sure if it links them
your best bet may be to slave this to your regular counter, there's a good explanation in the modding InfoCenter it is one of the weirdest things I've seen so far
have to go back and prod it some more
Admin of Randomness
retired moderator
#36 Old 7th Jan 2006 at 10:12 AM
I haven't delved far into the innards of objects, but I can tell you that I've downloaded various kitchen sets and simply the kitchen islands would not work for me, they wouldn't even appear in the catalog. It was declared an unsolved mystery. (I do have the original game only). So I can testify that those islands have given quite a few people problems. PM me if you want me to test a fixed version (if you can coax it into behaving)
The ModFather
retired moderator
Original Poster
#37 Old 7th Jan 2006 at 10:17 AM
This time SimPE is not to blame...

All the Maxis counter islands borrow the textures from the related kitchen counters: this can be seen (in the original island) reading the GMND, into the tsMaterialMeshName: there is a reference to the counter CRES.

When you clone the island as a Stand-Alone Object, all the tsMaterialsMeshName blocks are cleared up; in normal objects this is not a problem: the object simply refers to itself, when looking for the textures.
But with islands (and also kitchen counters) it is a problem, because islands and counters are "multi-model" objects (i.e. they change shape regarding their position).
Therefore, one of the CRES (the one with the shortest name) is to be considered the "main" one, and the others must be set as "slave" of the main one.

Do this:
1) open in turn the following GMNDs: ...endeast_tslocator, ...endwest_tslocator and ...-islandcornerquaint_root_rot; for each of them, select the tsMaterialsMeshName block;
2) add a "String" to the block
3) in the "Name" field type "countertop"; in the "String" field put the CRES name, without the _cres extension, but with the Forced Relocation prefix (i.e., in your case, ##0x1c050000!k8-oxygenisland-050106)
4) add another String; Name="counterfinish", String=the same CRES reference (##0x1c050000!k8-oxygenisland-050106)
5) repeat with the other two GMNDs

You might wonder why I've selected these three GMNDs and not the others; I've excluded all the GMNDs that only refer to shadows, and I've excluded also the one with the shortest name, because (looking at its name), it is related to the "main" CRES, and therefore it is to be considered the "main" GMND.

Note: the recolour package should work as is, once you have fixed the mesh package.

Note2: this procedure is valid if there isn't a custom counter to go with the island; if there is a counter, the procedure is slightly different.

I've finally started my Journal. Information only, no questions.

My latest activity: CEP 9.2.0! - AnyGameStarter 2.1.1 (UPD) - Scriptorium v.2.2f - Photo & Plaques hide with walls - Magazine Rack (UPD) - Animated Windows Hack (UPD) - Custom Instrument Hack (UPD) - Drivable Cars Without Nightlife (UPD) - Courtesy Lights (FIX) - Custom Fence-Arches - Painting-TV - Smarter Lights (UPD)


I *DON'T* accept requests, sorry.
Part-time Hermit
#38 Old 7th Jan 2006 at 1:26 PM
Numenor, I tried to do that to the island, as well, link it to itself, but when I tried to view it in the Scenegrapher afterwards, it would not open. I don't remember if I tested it in the game or not, though.
Test Subject
#39 Old 7th Jan 2006 at 8:48 PM
I have a question (or so) on renaming package files...

1. I've heard this but can't find it documented: You're supposed to package or zip your custom content from the SavedSims folder, not the Projects folder. I've been doing this blindly. Can someone tell me why, what's the difference, what can happen, etc?

2. Can you rename package files?
I've downloaded custom content before where it didn't have the body shop code in its name like "ghy06788_yada.package" and instead had the creator's name and whatever else. And then, those that have nothing but gibberish body code for their filename sucks, and I'd like to rename it to something recognizable and easy to organize somehow, like "creatorsname_AF-bluedress.package". Is it possible?
Part-time Hermit
#40 Old 7th Jan 2006 at 9:00 PM
Quote:
Originally Posted by jhayann1
I have a question (or so) on renaming package files...

1. I've heard this but can't find it documented: You're supposed to package or zip your custom content from the SavedSims folder, not the Projects folder. I've been doing this blindly. Can someone tell me why, what's the difference, what can happen, etc?

2. Can you rename package files?
I've downloaded custom content before where it didn't have the body shop code in its name like "ghy06788_yada.package" and instead had the creator's name and whatever else. And then, those that have nothing but gibberish body code for their filename sucks, and I'd like to rename it to something recognizable and easy to organize somehow, like "creatorsname_AF-bluedress.package". Is it possible?


There is actually a separate forum for skinning questions here, but I think I can answer your second question. Yes, you can rename your Bodyshop packages to anything you want, there doesn't need to be any gibberish code in it . Just make sure the name is different from other files that might be out there.
Test Subject
#41 Old 7th Jan 2006 at 9:13 PM
Quote:
Originally Posted by IgnorantBliss
Yes, you can rename your Bodyshop packages to anything you want, there doesn't need to be any gibberish code in it . Just make sure the name is different from other files that might be out there.


That's what I thought... The Staff at The Sims Resource said that you can :naughty: NOT rename it, especially to NOT touch the gibberish and the underscore (such as "hdfs76687_dress.package"). They just said Body Shop needs the code/gibberish, but couldn't explain further.

:haha: They're punks...
Guest
#42 Old 7th Jan 2006 at 11:15 PM
Default Created object replaces the original
I've created a new mesh by cloning one of the Maxis beds, however my mesh replaces the original and I've changed the guid and updated the MMats in the main object data file. I can't figure out what else could be wrong. Also, in-game, the new texture image and catalogue description don't even show up, only the original ones. Can someone please offer some guidance? Thank you.

Siri
Field Researcher
#43 Old 7th Jan 2006 at 11:17 PM Last edited by IgnorantBliss : 17th Feb 2006 at 7:45 PM. Reason: Removed old attachment
Quote:
Originally Posted by Numenor

Do this:
1) open in turn the following GMNDs: ...endeast_tslocator, ...endwest_tslocator and ...-islandcornerquaint_root_rot; for each of them, select the tsMaterialsMeshName block;
2) add a "String" to the block
3) in the "Name" field type "countertop"; in the "String" field put the CRES name, without the _cres extension, but with the Forced Relocation prefix (i.e., in your case, ##0x1c050000!k8-oxygenisland-050106)
4) add another String; Name="counterfinish", String=the same CRES reference (##0x1c050000!k8-oxygenisland-050106)
5) repeat with the other two GMNDs

Note2: this procedure is valid if there isn't a custom counter to go with the island; if there is a counter, the procedure is slightly different.


I've done this and its still behaving in the same way (see attached)(recolour showing as available in buy catalogue but doesn't update the counter when selected). There is a counter that looks as if it matches this island in my set but it isn't related in the sense you mean, they weren't cloned from an original pair of coordinating counter and island.

www.parsimonious.org
Artists - Get your own Studio! Always be featured!
Part-time Hermit
#44 Old 7th Jan 2006 at 11:49 PM
Quote:
Originally Posted by Siri_Io
I've created a new mesh by cloning one of the Maxis beds, however my mesh replaces the original and I've changed the guid and updated the MMats in the main object data file. I can't figure out what else could be wrong. Also, in-game, the new texture image and catalogue description don't even show up, only the original ones. Can someone please offer some guidance? Thank you.

Siri


Did you remember to also Commit with each GUID change? Did you change all the GUIDs, not just the main one?

To make the catalog text show correctly, make sure you click the button "default lang only" in the Catalog Description editing part in SimPE. This way, your description will show up in the language you wrote it no matter what language version the game is.

To update the catalog image for your bed, delete the thumbnail packages in the Thumbnails folder in your Sims 2 folder in My Documents.
Part-time Hermit
#45 Old 7th Jan 2006 at 11:52 PM
Quote:
Originally Posted by Pistachio
I've done this and its still behaving in the same way (see attached)(recolour showing as available in buy catalogue but doesn't update the counter when selected). There is a counter that looks as if it matches this island in my set but it isn't related in the sense you mean, they weren't cloned from an original pair of coordinating counter and island.


Kate, I think that regular counter is linked to your island. Only objects that borrow their materials/textures from other have the tsMaterialsMeshName in the Geometric Node, and your island does. It's just that making it a stand-alone clone removes the links that otherwise would be there.

That said, I still have no idea why it's not working. I will have to experiment with some counters and islands myself to maybe figure it out.
Guest
#46 Old 8th Jan 2006 at 12:43 AM
Quote:
Originally Posted by IgnorantBliss
Did you remember to also Commit with each GUID change? Did you change all the GUIDs, not just the main one?

To make the catalog text show correctly, make sure you click the button "default lang only" in the Catalog Description editing part in SimPE. This way, your description will show up in the language you wrote it no matter what language version the game is.

To update the catalog image for your bed, delete the thumbnail packages in the Thumbnails folder in your Sims 2 folder in My Documents.



I did change all of the GUIDS including the main one and I pressed 'commit' on all of the GUID changes the first time. The new object still overwrites the original.

Also, activating the 'default lang only' button fixed the issue with the catalog details.
Part-time Hermit
#47 Old 8th Jan 2006 at 12:46 AM
Quote:
Originally Posted by Siri_Io
I did change all of the GUIDS including the main one and I pressed 'commit' on all of the GUID changes the first time. The new object still overwrites the original.



In that case I can't say why it keep replacing the original object. Try posting your object here as an attachment and I'll take a look at it .
Guest
#48 Old 8th Jan 2006 at 12:52 AM Last edited by Siri_Io : 8th Jan 2006 at 4:25 PM.
Here it is. Thanks for checking it out.
Part-time Hermit
#49 Old 8th Jan 2006 at 12:59 AM
It'll be a few more hours before I'm at my own computer and able to work on package files, but I'll get back to this as soon as I can .
Part-time Hermit
#50 Old 8th Jan 2006 at 7:39 AM
Siri_Io, you have cloned the Colonial Hardwood double bed. That's probably the cause of your problem. You should clone any other bed than that. I'm not completely sure why it causes a problem, but I have a feeling it's got something to do with the fact that it's the Colonial bed that all the other beds borrow their bedding textures from. I have been told not to clone that one, although I don't remember being explained why. So, clone any other Maxis double bed instead, then import this mesh and textures to it, and re-use these GUIDs. It should work then .
Locked thread
Page 2 of 60
Back to top