Replies: 34 (Who?), Viewed: 54092 times.
Page 1 of 2
Test Subject
Original Poster
#1 Old 1st Dec 2010 at 4:17 AM Last edited by bstar84 : 1st Dec 2010 at 3:58 PM. Reason: Clarification, I do not think it is a problem with the world I'm using
Placed lot elevation problem
I'm using the Builder's Island world ( to create some houses to share. But whenever I place a lot I've built and saved, it has major elevation issues. (See pics below.) I noticed this once before on a different world with a different lot, but it wasn't nearly as bad as it is now. (ETA: I don't think this is an issue with the world, just noting it for reference.)

When I place the lot space, it's fine. I have gotten this problem having flattened the lot and having left it alone. When I place the lot itself, the entire space is either elevated or sunk into the ground. It's elevated or sunk all the way around; it never matches up to the level surrounding the lot. I have tried this in all different areas, different directions, same areas and directions, etc. It will even be completely different with the same house in the same area (see pics).

So... is this a normal problem or am I missing something? Is there a step I'm supposed to do to prevent this?

Veteran Finn
retired moderator
#2 Old 1st Dec 2010 at 5:45 AM
Hi there.

First of all I'd like to inform you, that cause this is an issue with someone's upload (in this case mine) the creator would appreciate that you posted issues concerning the upload to the upload post (not all creators follow the create-forums).

Posting here is a good idea also, so you could have many opinions if needed.

Sooo... I did some testing on the island, and I have to say I didn't manage to recreate the problem you have got. This makes me asume that it's not a problem with the world itself.

The buildable areas in the world are 64x64 on the other end of the island, and 30x30. See in this picture:

Looking at your pictures gives me the idea that you used the smaller side, and placed at least one lot outside the build area. So I did that too, but still didn't get any elevation problems.
I made this fugly little 10x10 testlot, and placed 4 copies of it to the smaller end, some of them way outside the buildarea. No elevation problems. See image:

So as closing, unless I start to get many many reports like yours, I have no reason to believe that the problem is in the world itself. I only have to wonder what you have done differently.

p.s. The roof is Tammy_trauma's, mentioning this just incase.
Test Subject
Original Poster
#3 Old 1st Dec 2010 at 6:33 AM
Originally Posted by armiel
Hi there.

First of all I'd like to inform you, that cause this is an issue with someone's upload (in this case mine) the creator would appreciate that you posted issues concerning the upload to the upload post (not all creators follow the create-forums).


So as closing, unless I start to get many many reports like yours, I have no reason to believe that the problem is in the world itself. I only have to wonder what you have done differently.

Sorry, didn't mean to imply that I thought the world was the problem! Going back to change the wording in a sec. I was just mentioning it as reference. I did have this problem in another world (CC I think). It is worse now but I think that's due to my own building methods, as I've worked without this problem on this world and others.

I am testing now in EA worlds, but it's 1:30am here so I will update tomorrow.

dodgy builder
#4 Old 1st Dec 2010 at 1:04 PM
I have used this world of Armiel many times. Have not had this problem.

I have heard about the problem though, but that's all I know.
Test Subject
#5 Old 3rd Dec 2010 at 10:30 AM
If you open the cheat console and type "help" without the quotes you should find a cheat to help with this problem. In mine it is "SetImportedTerrainOffset (value)" for the value use a positive number to move it one way and a negative number to move it the other way e.g 1 or -1
Test Subject
Original Poster
#6 Old 8th Dec 2010 at 3:23 AM
Originally Posted by Lacey010
If you open the cheat console and type "help" without the quotes you should find a cheat to help with this problem. In mine it is "SetImportedTerrainOffset (value)" for the value use a positive number to move it one way and a negative number to move it the other way e.g 1 or -1

Thanks!!! Annoying but it works, lol.
Field Researcher
#7 Old 15th Jan 2011 at 2:01 AM
I'm actually having this same exact problem after bringing over a lot from another player's world to work on in armiel's Builder's Island. I did my aterations, saved it to bin, tried putting it back on the same lot on the other player world and boom - same issue. Terrain elevated entire lot about 3-4 stories up in the air. Flattening the lot simply made the foundation elongated, house still up in air.

From my research this is happening to a lot of people. It's not armiel's world that I'm aware of or the other world I'm working in as its happening in lots of worlds - even EA ones.

The best fix I can find for it is here:

But even that one isn't working exactly for me. After moving everything back down (constrainfloorelevation false, then flatten lot) - the main floor is still one level up. I can hand move all items, windows, etc. but the lot is still borked by one level.

Apparently this started post-Ambitions.

If anyone else has any info on this issue or other workarounds, I'd greatly appreciate it!
Forum Resident
#8 Old 4th Feb 2011 at 12:14 AM Last edited by skmt999 : 4th Feb 2011 at 1:32 AM.
Well, this saves me from making a new thread. This is the first time I've really messed with saving lots to my bin for edtiing, testing and whatnot so I was really suprised when my lots got dropped into a crater or raised onto a cliff just by me placing it in a slightly different location. >.>'

I'm trying to get some lots ready for theoretic sharing, which I've never done before, being pretty insecure/selfish about my works. It's frustrating to finally think about uploading, only to see my stuff get made unusable.

So, from the link above I get the idea that this is just something that happens now and then - and it's up to the person placing the lot to make it work again? That's not reassuring.

And the help code "SetImportedTerrainOffset" ... so I have to do 1 for raising the ground and -1 for lowering it? Or... gah. I'll try it out but I think I've scrambled my brains for the day trying to fix things already. >.>'

Does this really happen that often, or is it just my bad luck?

- - - - - -

edit: I am also using the DIY island, and am about to try placing the lots I created there in another world to see if the issue is limited to when I place it in a different location on the same world I built it in - or if it just happens period. And it isn't ALL the time. I'd say one out of three placements work fine, the tinier the lot, the more likely it doesn't change elevation?

edit2: Eh. Placed one of my tiny houses built in DIY into Barnacle Bay as a good random place - and the lot sank straight into the ground about as deep as the house is tall. So. Now to build a tiny lot in Barnacle Bay and then place it in DIY to see if it's reciprocal.

edit3: Ok, so I made a house in Barnacle bay - used CFE as I always do, just to make sure. Went back into DIY Island to place it on an appropriate sized lot - worked fine! Deleted my bin house, went into the DIY placed house, messed with it, saved to bin, and then placed on a larger sized square on the other end of the island - instant crater. Backed out to Main Menu, switched back to Barnacle, and placed the newly-edited lot onto the same exact spot I'd had the original in - and got a crater.

So I'm seeing a pattern that this happens most often with houses I've saved, placed, edited and then REsaved to bin. Which is MADNESS. It means I have to build and decorate everything to it's final stages before ever saving it to my bin or it's elevations will get borked. >.>'
I don't know about other people, but I like tweaking things after I've done with them. I often forget to do things, or see a wall that I forgot to change...

Anyway, I hope someone else has more input on this odd problem.

- - - - -

last edit - ok, so I played with the terrainoffset thing. A value of [1] didn't help the crater much, but [5.5] made the ground flat again. I suppose I could always add this information to a read-me file, but... Ick.
dodgy builder
#9 Old 4th Feb 2011 at 10:22 AM
Well, I'm usually making my house in DIY, ready for testing, saving it and placing in another world for testing. Finished testing I go back to my original house before I saved it to the bin ... or what you call it. Do new changes to it, saving to the bin again and then I might try to test it again, or I just use it in another world.

Basically I don't change the house in other worlds I just keep it in DIY, and do the changes there. Then when I'm finished I save it to the bin and erase from DIY.

Edit: I don't have any troubles
The Camera Eye
retired moderator
#10 Old 4th Feb 2011 at 12:26 PM
For the people having this problem, let's see if we can find something common to all of your games.

Check your SKUversions- are each EP and Sp at the same patch level as the basegame?

It would be good if you could post your gameversions here so that we could compare.
My game worked file with all EPs and SPs patched up to level 009 in that table- I can build, lotbin, place the lot, build and lotbin again with no elevation problems.

Also, test to see if you get this problem with a clean set of userdata in case there is a mod or download causing this.

Also, what other details can you provide? For example, are you using any cheats, and can you download lots that others have made without this problem? For me, cheats make no difference- I never get a problem with the elevation. Also, I can download lots that others have made with no issues, even lots built on an older game version.

If people NOT having the problem can post some info too, it might help us find the cause!
In the Arena
retired moderator
#11 Old 4th Feb 2011 at 2:20 PM
In addition to simsample's points above, was the problematic Lot
- built from scratch in a specific world: SunsetValley, Twinbrook, Bridgeport, a custom one, etc...?
- a makeover of an EA Lot? (which lot of which world?)
- a makeover of a custom Lot build in one world by another player in another world?
- build on a smaller lotsize and placed in a different lotsize?
- totally flat or have elevated hills, bumps, stairs, basements?

Something to try on the weekend. Guess I have another project.

ps: sorry if the questions repeated tests you had done - I'm using this as a checklist to document for myself on things I need to test in point form
Forum Resident
#12 Old 4th Feb 2011 at 9:38 PM
I have just recently hand patched to the most up-to-date updates (level 10 on that chart) - since Launcher usually only patches Base and latest install, I have to do the rest myself.

Cheats used in the building of my problem lots - CFE and friezes for building, and moveobjects for decorating.

My tiny houses are using the stealth stair technique that I recently learned WAS usable still, as long as I deleted and then replaced the lot to test.

Built from scratch - among the tested culprits are three 10x10 tiny lots, one 20x20, and one older lot 30x30 which was where I first noticed the problem.

As a side note - I had started testing my earlier lots before the new patch and had never seen this before.

Things left in my mods folder - Awesomemod. I'd already taken everything else out for building my world and unrelated lots CC free.

Things left for me to test - modifying other people's lots ; verifying totally flat lot.

Now that it's brought up, I have to wonder about the flat lot being the culprit. Even after doing what I can to 'flatten' the lot, it seems I often run into issues where I want to extend the porch or something else and I get a message that it can't flatten the ground which I'd though was already flat. If that's all it is, then I just need to start using a different method to prepare my lot before I touch the wall tool.

It's either that or patch oddities.

I'll see what other fun tests I can do this weekend and post when I'm done with everything. If I'm lucky I can 'fix' this myself, lol.
#13 Old 6th Feb 2011 at 12:06 AM
Is this possibly an issue with creator's using CFE to build the lots they upload?

It's Life...there are no rules.
You can see more of my creations at
Forum Resident
#14 Old 9th Feb 2011 at 5:15 AM
Tested with one of pbox's Wee Barnoids, editing/resave-to-bin w. test name/place elsewhere on bigger lot - didn't give me any craters or cliffs.

Made a new test house using CFE, saved to bin and placed somewhere else - instant house on a cliff. I didn't even get to edit and place a second time.
(I did sooo many things to make sure the land was flat on this one. 'flatten lot' followed by dragging floor tiles from the street to the back, then hammering them gone so I could build)

Made a test Shed, like Armiel's test - rectangle with auto roof, stuck a door and one window just in case. Saved to bin and placed elsewhere. No elevation problems.
-- took SAME tiny test shed, modified it by dragging the walls bigger, and adding a second story with normal set of stairs. NO CFE. Saved to bin as test-test, deleted all currently placed lots back to a completely lot-less state and then added the right sized plot of land to place test-test upon - aaaand the house now sits on a nice cliff. Not as high as my others have been, but still.

So, it's not CFE related, but now we have 'stairs' as a common element.

I dunno. This really has me scratching my head. I'm going to play around with it some more, but I may have to give up on sharing anything for now. I'm also going to uninstall and then reinstall all of my 'hoods just in case something got corrupted. Weirder things have happened.
dodgy builder
#15 Old 10th Feb 2011 at 12:26 PM
Cred to skmt999 for doing this. I know it's a lot of work.
Veteran Finn
retired moderator
#16 Old 20th Mar 2011 at 2:15 PM
Here is more info on how to correct the lots with SetImportedTerrainOffset (value), thanks for Whitey for the heads up. http://oumamea-the-sims3.blogspot.c...nto-ground.html
Forum Resident
#17 Old 16th Aug 2011 at 3:55 AM
As a note to add to the possible CAUSES of this for most people.... It just happened again to a lot I was working on (underground Fallout style bunker/vault). I'm seeing a pattern here.

It happens to lots that: I work on then save to bin - then quit without saving the world I'm in. The next time I want to work on my lot, I open the game, open a fresh world, and place a lot of the right size, then my Lot. Work on it, then save to bin again, deleting the old one (I'm now realizing I should keep multiple backups of complicated lots like tombs...). The third time, sometimes the fourth time, I rinse and repeat - when I next place the lot, it's elevation is wonky.

I've NEVER had this happen to lots that I have saved to bin after working on it to completion in one go. It's only the ones that I've gone back to and edited after saving to bin, then re-saved it, to place one more time and test.

Considering that I refuse to consider sharing a lot with wonky elevations, that means that all my work up until now is pretty much wasted time. I can re-do a lot of it but.... it won't be the same, and I'll be in a hurry because I hate re-doing things.

Most of the lots I like to mess with have some sort of CFE wizardry going on, I'm wondering if some numbers get scrambled after being re-worked on? But this is conjecture. I'm pretty sure I did a test home ages ago with NO CFE, and it still happened.

I just wanted to put up my flash of inspiration on the topic, to see if this matches up with anyone else who's had this happen to them more than once. I mean, for a lot meant just for myself, I'd just finish it and use the setimport cheat - but I can't expect other people to do that. I just want to just plop and play with other people's lots, after all. Why assume otherwise for everyone else?
Test Subject
#18 Old 9th Mar 2012 at 8:09 PM Last edited by ChloeSMV : 9th Mar 2012 at 9:07 PM.
Not working, unfortunately!
Hello everyone. I`m new to TS3. Got the base and all EPs/SPs last weekend, and I was amazed by it during these last four days, even though lots of things I love about TS2 are missing on it (like Yoga, or harvesting your own fruits and making juices, seasons, setting relationships on CAS instead of having just ``housemate`` forced on us, making a baby/child/teen by combining DNA info from two adults in CAS, having a gardener in ``call for services``, ordering chinese food, etc...). But today I re-registered here on MTS (idk, my last account was probably expired or something), and I downloaded this customized house, and, as you can imagine, I got to know this bug.

It`s really annoying. I spent the last four hours trying to solve it, with all the tips from you guys on this thread.

But, oddly enough, nothing works for me. Not even ``SetImportedTerrainOffset value``. I type it, with negative or positive values, and I don`t see the lot changing at all on screen. Nothing else left to do for me but move my Sim to a lame Maxis house in Appaloosa Plains if I want to get some gameplay time today.

I tried the ``constrainFloorElevation`` and sledgehammer ``fix``, but, it works and doesn`t at the same time. Windows and walls are all wrong, the walls keep blinking between their painted texture and pure cement, the windows lose their grid and transparency.... it`s not really a fix, if you ask me, even though the elevation gets fixed, more or less. If anyone really knows how to fix a house doing this, congrats, you`re very skilled. For hours, I tried and tried, and nothing worked.

I`ve read a lot about this issue today, and it seems it started with ``Ambitions``. It`s amazing how a huge game manufacturer AND Will Wright didn`t care about patching this on their multi-gazillion dollar maker title.

I think the community should make a petition about this and send to EA and Will, kinda forcing them to fix this bug. Since June 2010, and no patch ? It`s unbelievable. Are they professional programmers or what ?

Cheers, everyone.
Forum Resident
#19 Old 9th Mar 2012 at 8:32 PM
Originally Posted by ChloeSMV

But, oddly enough, nothing works for me. Not even ``SetImportedTerrainOffset value``. I type it, with negative or positive values, and I don`t see the lot changing at all on screen. Nothing else left to do for me but move my Sim to a lame Maxis house in Appaloosa Plains if I want to get some gameplay time today.

Cheers, everyone.

It's not really clear on here what exactly to do, but the "SetImportedTerrainOffset" works.

1. lay down the empty lot space you need.
2. Go into buy/build for the empty lot.
3. Use "SetImportedTerrainOffset" If your lot sinks use a number around 3, I think 2.8 is flat. Nothing actually happens that you will see.
4. Go back into edit town and place your lot on the empty one.

It should be correct now if you did it right.
Test Subject
#20 Old 9th Mar 2012 at 10:49 PM Last edited by ChloeSMV : 10th Mar 2012 at 2:38 PM.
Thank you!
Thanks!!! It worked now. Honestly, though, I don`t know what I did different this time around, compared to my previous attempts.

At least now I can play in the house I downloaded.

Thanks for helping me, omegastarr82.
One horse disagreer of the Apocalypse
#21 Old 7th Aug 2013 at 9:00 AM
I can make this work in everything *except* the actual problem I was trying to solve - one particular lot in one particular place! Trying to place the Starfish Sands Playground from Sunlit Tides (the non-festival version)into a beach lot in Sunset Valley. I can place this lot inland and use the cheat to raise it and lower it as expected. I can place another lot on the beach and use the cheat to raise and lower the lot as expected. But *this* lot on *this* location is completely ignoring my cheat as if I had typed nothing!

I'd be very interested if someone else could try the same combination so I know if it's just me!

The location I am trying is a new lot I created to the left (as you look inland from the sea) of Old Pier Beach

"You can do refraction by raymarching through the depth buffer" (c. Reddeyfish 2017)
mature minion
retired moderator
#22 Old 7th Aug 2013 at 10:01 AM
beach lots unfortunately ignore the cheat completely since patch 1.55 and it is highly annoying
One horse disagreer of the Apocalypse
#23 Old 7th Aug 2013 at 10:50 AM
Oh... Well at least I can stop trying lol(?) Maybe there is a new cheat to discover for beach lots? (she says brightly)

"You can do refraction by raymarching through the depth buffer" (c. Reddeyfish 2017)
dodgy builder
#24 Old 7th Aug 2013 at 3:18 PM
I was trying to fix a tiny routing issue in caw the other day on a beach lot, clicked on that button compiled or what it's called, and the entire thing dropped down looked silly. Beach lots seems to be buggy in all possible directions.
mature minion
retired moderator
#25 Old 7th Aug 2013 at 3:48 PM
If you do work it out I'd love to know! I've been trying to do sneaky things with beach lots but the setimportedterrainoffset cheat not working is greatly frustrating my efforts
Page 1 of 2
Back to top