Replies: 21 (Who?), Viewed: 6247 times.
Sockpuppet
Original Poster
#1 Old 10th Jun 2012 at 12:02 PM Last edited by Kabuto : 3rd Jul 2012 at 7:51 PM.
[SOLVED] Import mesh crashes TSR Workshop
Hi,

I'm trying to adjust a WOE nipple rings because it doesn't match with my favorite skintone.

I edited this custom mesh, just I moved the XYZ position and I updated the morph with Wes' Morph Mangle but TSRW 2.0.41.0 always failed when I want to import the new mesh.

Then TSRW ask to save the project before leaving.

If I save it, the project cause a "SmartExceptionsCore.UnhandledException @ 6867, offset:56" and a "D3DERR_INVALIDCALL: Invalid call (-2005530516)"

How can I change the mesh and morph without TSRW ?
Advertisement
Ms. Byte
#2 Old 10th Jun 2012 at 10:01 PM
Is the TSRW mesh in .wso form, and all you're doing is moving the vertices of the ring and updating the morphs with MorphMangle, then exporting from Milkshape as .wso? What happens when you try to replace the mesh in TSRW?

If this CC is in a package, you can extract, modify, and replace the base mesh using S3PE and Milkshape. There's probably no need to update the morphs as long as you don't renumber the vertices but you'll have to test that. If it's not a package but you can open it in TSRW, try using Edit/Package Contents/Export to convert to a package.
Sockpuppet
Original Poster
#3 Old 10th Jun 2012 at 10:09 PM
Yes, it's a Sims3Pack I'm trying to edit with TSRW and Milkshape.

The result should be the same if I replace the GEOM files in the package ?

Then I'll try this way, thank you !
Sockpuppet
Original Poster
#4 Old 23rd Jun 2012 at 12:19 PM
Well, I tried but the base mesh broke the morphes and don't fit anymore to the amTopNude mesh in CAS
Ms. Byte
#5 Old 23rd Jun 2012 at 1:55 PM
Can you upload the WSO mesh that's crashing TSRW?
Sockpuppet
#6 Old 23rd Jun 2012 at 9:05 PM
problem is that stuff created with older versions of tsrw dont work well with the latest.
Sockpuppet
Original Poster
#7 Old 24th Jun 2012 at 7:47 PM Last edited by Kabuto : 3rd Jul 2012 at 7:51 PM.
I don't understand why the GEOM file failed too.
Ms. Byte
#8 Old 24th Jun 2012 at 9:04 PM
Your base and special mesh groups don't have valid bone assignments. That's probably what's crashing TSRW.
Mother Function
retired moderator
#9 Old 24th Jun 2012 at 9:46 PM
Tried importing the mesh into Milkshape and the saving it as an obj file? Then, reimporting, reassign bones, and then exporting back out as a .wso?

"Holy Shift! Check out the asymptotes on that mother function!"
Sockpuppet
Original Poster
#10 Old 24th Jun 2012 at 10:18 PM Last edited by Kabuto : 24th Jun 2012 at 10:32 PM.
CmarNYC, you're right, in Milkshape 3D, now the b__Spine1__ bone is assigned to the whole mesh, TSRW can import it properly.

The orignal mesh used these bones :

b__Spine1__
b__L_Mid2__
b__L_Clavide__
b__R_Clavide__

I don't know what the bones I need or how can I automatically assign the good bones ?


EDIT: I begin to understand how I can do it, just I use the TSRW Vertex editor, now I can see how the bones are assigned in the original mesh.


Thank you for your help, I'll try it.
Ms. Byte
#11 Old 24th Jun 2012 at 11:24 PM
All the verts were actually assigned to nothing - a non-existent bone.

One of the things I want to add to my MeshToolkit is a way to copy values (like bone assignments) from one TSRW mesh group to another, so in this case you'd be able to copy the bones from one of the morphs to the base. If you can't get it working or it's taking a long time, you can try that when I finish it, maybe in another day or two.
Sockpuppet
#12 Old 24th Jun 2012 at 11:45 PM
i tried to do the above with a custom mesh(GEOM) but it crashed Toolkit.
I have to say it was a veryhigh polygon of 12000, and that was only one half the body.
Maybe i can sent it to you so you can test to the edge :D

Ms. Byte
#13 Old 25th Jun 2012 at 1:04 AM
Sure, Bloom - beautiful mesh. Either upload or email it - I'll pm you my email. What were you trying to do with it in Toolkit exactly?
Sockpuppet
#14 Old 25th Jun 2012 at 10:38 AM
the individual meshparts are assigned to one bone.
so the whole foot to a footjoint, calf to calf.
I wanted to see wether i could finetune it with meshtoolkit.
Ms. Byte
#15 Old 25th Jun 2012 at 1:10 PM
Did you try the bone auto assign? What happened?
Sockpuppet
#16 Old 25th Jun 2012 at 2:40 PM
it crashed
Ms. Byte
#17 Old 25th Jun 2012 at 3:17 PM
Can you upload or send the mesh so I can test?
Sockpuppet
#18 Old 25th Jun 2012 at 3:43 PM Last edited by BloomsBase : 25th Jun 2012 at 3:56 PM.
yes, i will
i only have half a mesh, it is to big to duplicate, mirror and regroup.
Ill have it as simbot, ill send you the package(it is a replacement i done a long time ago.)
Not finished ...

edit,
you got a pm with link.
I was planning to add a meshgroup for the other half but i kinda gave up on her..
But your tool gave me hope, so i gave it a try
Ms. Byte
#19 Old 26th Jun 2012 at 4:39 PM Last edited by CmarNYC : 27th Jun 2012 at 9:37 PM.
Got the bone auto-assign fixed - as usual it was a fairly dumb coding error. Corrected Toolkit attached. Now, whether the auto-assigned bones actually WORK is a different matter. I used a bathing suit body as reference mesh for the body and made a complete head in Milkshape as reference mesh for the head, btw. If you want the auto-assigned meshes just let me know. Now I need a break for brunch.

Please download from this thread: http://www.modthesims.info/showthread.php?t=472326
Sockpuppet
#20 Old 26th Jun 2012 at 4:46 PM
Enjoy, and thank you so much for all you do for us!
Sockpuppet
#21 Old 26th Jun 2012 at 5:38 PM
omg....it works!
I prolly need to finetune some areas but it doesn't look bad at all in MS(ANIM and rotated joints)
Ms. Byte
#22 Old 26th Jun 2012 at 5:58 PM
That's a good sign! Let me know how it goes in-game.
Back to top