Replies: 0 (Who?), Viewed: 58 times.
Test Subject
Original Poster
#1 Old 23rd May 2022 at 10:43 PM
Default Need Help With Resizing Existing Distant Terrain
Hello! I would like to preface this post by saying that I am very new to all of this - CAW, meshing and stuff, and this forum. (I've used MTS for a while of course but I've never posted until now, and I'm not sure I put this in the right category, so my apologies if it isn't the right one), and I'm not sure if the CAW community is that active nowadays? But I figure I'll try my luck here.
I had a question about distant terrain in Sims 3 CAW. Since this is my first complete world, I'd like to make a small world. I was thinking of making a mountain town-esque (I use this descriptor very lightly) type of world, loosely based on where I grew up.

I would like to use Sunset Valley's distant terrain, scaled down to fit small worlds. I've searched the forums for an idea on how to go about doing this, and I actually did find a thread. But none of the things listed there worked for me, and it hasn't been updated since 2013. From my understanding, I need to use S3OC and clone the package for Sunset Valley's distant terrain - TerrainDistant. I've done this and it's worked smoothly, but here's where I've hit a problem.
The thread I found gave me two options

1) Open the cloned TerrainDistant package in s3pe, then export the MODL to a s3asc file
2) Import MODL/s3asc to Milkshape, scale it down to 25%, then export and save over the original (I believe I have all the plugins needed for Milkshape as the .s3asc file imports and scales without problems)
3) Import MODL back to s3pe, then save the package file
4) Edit values in S3PE with the "grid" option to make the file appear in CAW metadata, then add the package to your regular sims 3 mods folder and the CAW packages directory (I've already edited the resource.cfg and other custom distant terrains work fine, so I'm pretty sure it's not a problem with that |this is the tutorial I'm using )

This method seems pretty easy, but I've tried it a few times, and all of the times I've tried it, the file didn't show up in CAW metadata. Steps 1-2 seem to go fine but when I put the edited MODL back into s3pe, the side panel reads an error, rather than what it read with the original, unscaled MODL.
Code:
Error reading resource 0x01661233-0x00000001-0x000000000073E4AD
Front-end Distribution: 17-0520-1821
Library Distribution: 17-0520-1821

Source: mscorlib
Assembly: mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
Exception has been thrown by the target of an invocation.
----
Stack trace:
   at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor)
   at System.Reflection.RuntimeConstructorInfo.Invoke(BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
   at s3pi.WrapperDealer.WrapperDealer.WrapperForType(String type, Int32 APIversion, Stream s)
   at S3PIDemoFE.MainForm.browserWidget1_SelectedResourceChanged(Object sender, ResourceChangedEventArgs e)
----

Source: mscorlib
Assembly: mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089
Unable to read beyond the end of the stream.
----
Stack trace:
   at System.IO.__Error.EndOfFile()
   at System.IO.BinaryReader.FillBuffer(Int32 numBytes)
   at System.IO.BinaryReader.ReadUInt32()
   at s3pi.GenericRCOLResource.GenericRCOLResource.Parse(Stream s)
----


I didn't notice this at first, and continued the process with the error MODL file, which is why I suspect it doesn't work properly. What I'm stuck on is how to fix this error. Like I said I'm quite new to this and don't really understand the error

This was the second option to resize the distant terrain, which also didn't work.

1) Load the cloned TerrainDistant package file into TSR workshop
2) Go to mesh tab and extract in .WSO format
3) Load WSO into Milkshape and scale it down (again I'm pretty sure I have all the right plugins as it imports and scales without problems)
4) Import scaled down WSO into TSR Workshop
5) Save as .sims3pack and install with launcher

This method goes smoothly until step 4; when I import the scaled down WSO into the mesh tab of TSR, I get this message

Quote:
This object uses a vertexdeclaration with a usageindex that is non-zero, this means that when exporting/importing this mesh the normalmap data (and possibly other data) will be lost. This will probably result in an object that does not look good (or even work at all) in game. Do you want to continue?


I click yes when it prompts me if I want to continue and I can proceed with the rest of the steps smoothly - but I have a feeling that this error could possibly be the reason that this method isn't working. When I install as a .sims3pack through the launcher, it doesn't show up at all, much like the other method. I've tried exporting as a package by going to Tools>Project Contents>Export>To .package (exporting as a package file from File>Export is grayed out), modding it to show up CAW metadata and it still didn't show up in CAW.

It's definitely not impossible that I'm missing something obvious. But with the limited resources online about CAW, especially about distant terrain, I'd appreciate all the help I can get. Thank you in advance to anybody who helps
Back to top