Locked thread | Replies: 129 (Who?), Viewed: 46696 times. | Locked by: simsample Reason: Outdated, now we are on version 1.47
Page 1 of 6
Field Researcher
Original Poster
#1 Old 29th Oct 2012 at 10:17 PM Last edited by TVRdesigns : 2nd Nov 2012 at 9:55 PM.
Default 1.42 and CAW. Does it work? ##Thread for CAW issues with new Patch##
Has anyone updated their game to 1.42 yet? I'm curious as to whether EA have updated CAW at the same time. I'd just update myself and wait it out if it doesn't work, but I have a world in CFF that I'm trying not to neglect. :P

*EDIT* I updated the title to reflect the current nature of this thread. Hopefully if the title is clearer, we can get some more people telling their issues, or even a fix or work-around they have stumbled across.

I didn't see you there. Hello. *runs* | Visit my CFF World thread
Advertisement
One horse disagreer of the Apocalypse
#2 Old 29th Oct 2012 at 10:56 PM
My existing CAW stopped working. Don't know if they released new one yet.

"You can do refraction by raymarching through the depth buffer" (c. Reddeyfish 2017)
Lab Assistant
DELETED POST
30th Oct 2012 at 4:18 AM Last edited by PWN9483 : 6th Nov 2012 at 8:04 PM. Reason: added additional information
Ran as Admin - solved EIG crash
This message has been deleted by PWN9483. Reason: Updated info into to a new reply
In the Arena
retired moderator
#3 Old 30th Oct 2012 at 2:55 PM
@Tom, I have. Game Help:Patch_Tablewiki
You could always check that Wiki for the version numbers when a new patch rolls around. I try to keep it up-to-date.

CAW is at 1.18.4, which I find odd (see image), but it loads. EIG is crashing on me though. But that is with a modified Store World, so there may be some CC-linkages I'm missing somewhere.
Screenshots
Test Subject
#4 Old 30th Oct 2012 at 5:28 PM
Default I'm having an issue
I'm new to CAW but I've played with it some and have had to update it 2 different times (because of supernatural and seasons coming out).

It worked perfectly until I updated it yesterday. Now, just about everytime I edit in game, when I save and go back to CAW, all my lots have disappeared! Then, even if I goto old saves, the lots in those have disappeared also.

Everything else is still left, like objects in the world, roads, trees, ect. Any ideas on what is happening?

It's such a big issue that I finally signed up for this site to ask you guys directly.
Test Subject
#5 Old 30th Oct 2012 at 5:40 PM Last edited by happyscrub : 30th Oct 2012 at 6:00 PM.
I'm too scared to touch CAW now. Everytime I do, I'm losing days of work because lots are disappearing by the second.

edit: I found a backup of a file with recent work. So I'm not so mad now. I'm still scared to go any further until I can find out what the heck is making all the lots disappear.
Field Researcher
Original Poster
#6 Old 31st Oct 2012 at 2:08 AM
Yes, I just experienced this as well. Looks like I'll be postponing working with CAW until a fix is found.

I didn't see you there. Hello. *runs* | Visit my CFF World thread
In the Arena
retired moderator
#7 Old 31st Oct 2012 at 9:04 AM
I believe now there are issues even with CAW 1.19 with patch 1.39. I've been having saving issues since that version that I originally attributed to my world saves being in a Junction folder, and not in the default User folder path directly.

I'm rolling back (to 1.18.3 and perhaps even older) to test a theory...
Field Researcher
Original Poster
#8 Old 31st Oct 2012 at 10:08 AM Last edited by TVRdesigns : 31st Oct 2012 at 1:37 PM.
I'm curious, and this might be a stupid thought.. But does it work any different in SuperCAW? I realise they're the same.. But. I dunno. Something to try..

Another thing I just thought of was.. Does this affect only pre-existing .world files created with previous versions of CAW? Or does it do the exact same thing to brand new worlds created fresh with this new CAW version.. I know that pre-existing EXPORTED worlds work (according to EA), but maybe the new patch adds files to the sims3packs when they're imported into the new game.. Wheras CAW doesn't have the same functionality.. I was thinking about it, and maybe it has something to do with the added Seasons functionality of the new patch. The new patch adds a 'Seasonal Lot Marker' to the buydebug menu ingame. Maybe its deleting the current lots because they weren't created with some sort of new framework in place?

Though.. Don't take my word for it. I have absolutely no clue how EA's file formats work, and when I try changing any file formats in The Sims 3, mice have a habit of being thrown. <.<

I didn't see you there. Hello. *runs* | Visit my CFF World thread
In the Arena
retired moderator
#9 Old 1st Nov 2012 at 11:30 AM
Nope, SuperCAW didn't help.
I tested with both my own compiled code and to rule out the possibility of me making a mistake while following the guide, also used atavera's pre-compiled exe. Same results.

Thread @ official forums to gather data for the CAW devs. http://forum.thesims3.com/jforum/posts/list/604830.page

I agree with the theory on Sims3Pack file formats possible being changed. The way the Lots and worlds are modified for Seasons may have something to do with the Sim3Packs file format having changed. Lots of threads on Sims3Packs not installing now in various forums. Have to wait for someone to poke into the file format to confirm...*squints at Inge.
Test Subject
#10 Old 1st Nov 2012 at 10:52 PM
I think they put out a hotpatch

http://forum.thesims3.com/jforum/posts/list/605280.page

I only tested it once, but my lots didn't disappear on my 1st attempt to save in EIG mode.
Alchemist
#11 Old 2nd Nov 2012 at 12:01 AM
Didn't work for me. I still keep getting read-only lots -warnings when trying to save.
Test Subject
#12 Old 2nd Nov 2012 at 12:32 AM
Now i'm not able to install my worlds after I export them.
Alchemist
#13 Old 2nd Nov 2012 at 1:03 AM
That still seems to be one of the CAW issues that EA needs to fix.
Field Researcher
Original Poster
#14 Old 2nd Nov 2012 at 2:17 AM
Yeah, I've got that error now. It 'installs', but when you go ingame or restart the launcher, it says its not installed. Stupid thing.. Oh well. Guess we'll have to wait again for another patch.

I didn't see you there. Hello. *runs* | Visit my CFF World thread
Test Subject
#15 Old 2nd Nov 2012 at 11:52 PM
TVRdesigns, thanks for your replay. Makes me feel a little better that the issue is the fault of ea, not something I did my self.
Lab Assistant
#16 Old 6th Nov 2012 at 8:06 PM Last edited by PWN9483 : 7th Nov 2012 at 2:48 AM.
Tried this and it works, so far
Steps tried without luck
- Uninstalled CAW, removed all related files, mods, objects. Reinstalled CAW.
- Created a new world, added 1 lot, no other details, opened in EIG, crashes to Desktop leaving CAW remaining open.
- Set TS3 and related EPs to not use D.E.P.
- Set CAW and TS3 exe's to run as Administrator - actually seemed to work for a while, but alas... back to crashing when loading the 2nd stage of EIG.

What worked (so far):
http://forum.thesims3.com/jforum/po...30.page#9732923
Test Subject
#17 Old 7th Nov 2012 at 8:53 AM
well i got it to work just fine. thanks to all the tipps . what i did was:

1: Deeinstall CAW
2: Downloaded CAW exe (today- dont know if its the same as a few days ago)
3. Let my game generate a new Sims 3 folder so that it is 100 % CC free
3a. Made the Folder "FeaturedItems" in "My dokuments - ElectronicArts - Sims 3" to a "read only" folder to reduce lagg for me (prolly not neccessary for u all)
4. Installed CAW
5. Opened CAW and closed it again
6. Deleeted all the files in the folder "My dokuments - electronic arts - Create a world - user tool data - SourceTextures".
7. i placed all my downloaded and created custom Paints in this above mentioned folder. (i made a complete copie of the old folder be4 the last patch update)
8. opend CAW created a small test isle...with a road...a waterfall one community lot and a streetlight. a bit paining and routing. saved and EIG. build a small house with a rappidhole underground.
9. when done in EIG i ended the EIG when it asked me if i wanna save..i saved the world...waited a bit pressed ok and went back to CAW tool. (while loading EIG and saving from EIG i had it minimized)
10. fast pic and short name and so added. then exported.

Done

hope that can help some of u too.

only problem:

i extracet the world to a .package BUT: How can i change the .package to a .world? if i wanna rename it just wanna change all be4 the .package ( to get the world in my game like Inge Jones mentioned)

sy for my bad english im good in reading understanding english, but not in writing
Alchemist
#18 Old 7th Nov 2012 at 11:39 AM
Did you actually tested it with an old world, as well? I've put a year and half into my world already and there's no way that I'm starting over again. I refuse to do that.
Test Subject
#19 Old 7th Nov 2012 at 5:50 PM
soo. jup i finaly found out how to change the .package into a .word. so yes i did this now with a test world and my recend world build project. (so u can say an old world). both work fine. and are playable with using the .world file.. gl to u too.

by the way. to be sure; just do it with a copie of ur world files first so if it realy shouldnt work u still wont loose ur files.
Lab Assistant
#20 Old 7th Nov 2012 at 6:41 PM Last edited by PWN9483 : 7th Nov 2012 at 9:49 PM. Reason: added details
Quote:
Originally Posted by varpunen
Did you actually tested it with an old world, as well? I've put a year and half into my world already and there's no way that I'm starting over again. I refuse to do that.


CAW WORKS for editing games...
Here's what I tested.

Moved my custom package and paints out of the various locations.
Uninstalled CAW, reinstalled the downloaded CAW.

Shows as Codeversion.txt: description=Version: 0.RL-2.0.190 Changelist: 1084082
Shows as Default.ini: GameVersion = 1.18.5.019037, CompatVersion = 19, WorldBuilderCompatibilityVersion = 16
Shows as Worldbuilder.ini: WBVersion = 1.18.5.019037

Note: CAW is now LAA, no need to apply the LAA fix re: http://forum.thesims3.com/jforum/po...30.page#9702251

Created a new world and saved to generate the folder and file structure in the documents folder:
C:\Users\YOURLOGINNAME\Documents\Electronic Arts\The Sims 3 Create A World Tool

Then moved the default paints in that location to my desktop (in a folder).

Recreated the CAW framework (resource.cfg) and package folder in:
C:\Program Files (x86)\Electronic Arts\The Sims 3 Create a World Tool

Added my custom paints (all in their own folders) back into:
C:\Users\YOURLOGINNAME\Documents\Electronic Arts\The Sims 3 Create A World Tool\UserToolData\SourceTextures

Opened CAW, opened an OLD world, SAVE AS to make a copy, then edited in game (EIG), added some stuff to various lots, saved then quit EIG. Once back in CAW saved, closed CAW, started CAW again, opened the edited world, all lots are there, changes made show.

EXPORT/INSTALL is troublesome
The only issue remaining is exporting/installing the world now. Export works, but installing the exported world is problematic. Still working through this issue. I have the exported world Sims3pack file, it shows as installing, but doesn't actually install.

What I have tried on exporting/installing:
Exported my world. It places the sims3pack in the C:\Users\YOURLOGINNAME\Documents\Electronic Arts\The Sims 3\Exports location.
If I go to the launcher and select install, it goes through the process, shows a dialog saying installed, the process copies the sims3pack to the C:\Users\YOURLOGINNAME\Documents\Electronic Arts\The Sims 3\Downloads folder. Same thing if I moved the sims3pack out of the exports and try installing by double clicking the file. It says it installs but doesn't actually. If I go to the launcher under the Installed Content selection, the world shows as uninstalled. If I try activating the world from this location it goes through the same process, saying it installs, even shows the little icon as stating installed... but it doesn't show while in the game under the New Game option... Older worlds that were already installed do show and work including Hogwarts wizarding world

Work Around:
Seems there's a workaround to getting worlds exported then working in game. See this thread: http://www.modthesims.info/showpost...644&postcount=5
Alchemist
#21 Old 7th Nov 2012 at 7:18 PM
Okay, thank you for the info. I'll have to try it out.
Test Subject
#22 Old 7th Nov 2012 at 8:54 PM
I can't even open CAW. I've tried uninstalling it and downloading and reinstalling again but nothing. It worked for me before 1.42
Test Subject
#23 Old 8th Nov 2012 at 12:10 AM
Is anyone here getting disappearing buildings on lots.
Field Researcher
Original Poster
#24 Old 8th Nov 2012 at 2:15 AM
kwetzel, explain your issue further. There was an issue where CAW would delete the actual lots after loading EIG and exiting and going back into CAW. Is this what you mean?

I didn't see you there. Hello. *runs* | Visit my CFF World thread
Lab Assistant
#25 Old 8th Nov 2012 at 9:57 PM
Default Another work around
Another much simpler work around which simply edits the default.ini

http://forum.thesims3.com/jforum/po...30.page#9737057

As always, some things work for some systems and some don't. Hope next Tuesday (seasons) solves all these issues.
Locked thread | Locked by: simsample Reason: Outdated, now we are on version 1.47
Page 1 of 6
Back to top